Diff for /wikisrc/tutorials/pkgsrc/clang.mdwn between versions 1.3 and 1.4

version 1.3, 2017/12/30 17:51:05 version 1.4, 2017/12/30 17:58:58
Line 25  generated from gcc to those generated wi Line 25  generated from gcc to those generated wi
   
 # Using clang from pkgsrc  # Using clang from pkgsrc
   
 You can build clang from pkgsrc (lang/clang).  However, it need  You can build clang from pkgsrc (lang/clang).  However, it needs
 libstdc++ from the base system, and thus this will only work on  libstdc++ from the base system, at least from gcc 4.8 or higher.  It
 systems that natively have gcc if the version is 4.8 or higher.  also depends on cmake, which requires c++11, which needs gcc 4.8 or
   higher.  So this will not work on NetBSD <= 6.
   
 Once built, you should (\todo test this) be able to set:  Once built, you should (\todo test this) be able to set:
   
     PKGSRC_COMPILER=       clang      PKGSRC_COMPILER=       clang
     CLANGBASE=             /usr/pkg      CLANGBASE=             /usr/pkg
   
   and perhaps
   
       HAVE_LLVM=             yes
   
 The caveats above about using a consistent compiler apply.  The caveats above about using a consistent compiler apply.

Removed from v.1.3  
changed lines
  Added in v.1.4


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb