Annotation of wikisrc/projects/project/secureplt.mdwn, revision 1.1

1.1     ! jmmv        1: [[!template id=project
        !             2: 
        !             3: title="Secure-PLT - supporting new PLT formats on alpha"
        !             4: 
        !             5: contact="""
        !             6: [tech-userlevel](mailto:tech-userlevel@NetBSD.org)
        !             7: """
        !             8: 
        !             9: mentors="""
        !            10: [Christos Zoulas](mailto:christos@NetBSD.org)
        !            11: """
        !            12: 
        !            13: duration="3 months"
        !            14: 
        !            15: description="""
        !            16: Currently kernels with options PAX_MPROTECT can not execute dynamically linked binaries on most RISC architectures, because the PLT format defined by the ABI of these architectures uses self-modifying code.
        !            17: 
        !            18: New binutils versions have introduced a different PLT format (enabled with --secureplt) for alpha and powerpc.
        !            19: 
        !            20: This project (for alpha) is to add support for the new PLT formats introduced in binutils 2.17 and gcc4.1 This will require changes to the dynamic loader (ld.elf_so), various assembly headers, and library files.
        !            21: 
        !            22: Support for both the old and new formats in the same invocation will be required.
        !            23: 
        !            24: For all architectures we can improve security by implementing [relro](http://tk-blog.blogspot.com/2009/02/relro-not-so-well-known-memory.html).
        !            25: """
        !            26: ]]
        !            27: 
        !            28: [[!tag gsoc]]
        !            29: [[!tag medium]]
        !            30: [[!tag userland]]

CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb