Diff for /wikisrc/ports/xen/howto.mdwn between versions 1.130 and 1.132

version 1.130, 2016/12/20 19:47:35 version 1.132, 2016/12/20 19:59:38
Line 113  need to use xm instead of xl, or if you  Line 113  need to use xm instead of xl, or if you 
 xenkernel45 provides Xen 4.5.  As of 2016-12, security patches were  xenkernel45 provides Xen 4.5.  As of 2016-12, security patches were
 released by Xen and applied to pkgsrc.  Xen 4.5 requires using a dom0  released by Xen and applied to pkgsrc.  Xen 4.5 requires using a dom0
 running NetBSD's amd64 port (Intel or AMD hardware is fine), but domUs  running NetBSD's amd64 port (Intel or AMD hardware is fine), but domUs
 can be amd64 or i386 PAE.  TODO: It is either a conservative choice or  can be amd64 or i386 PAE.  While slightly old, n4.5 has been tested and
 somewhat old.  run by others, so it is the conservative choice.
   
 xenkernel46 provides Xen 4.6.  It is new to pkgsrc as of 2016-05.  As  xenkernel46 provides Xen 4.6.  It is new to pkgsrc as of 2016-05.  As
 of 2016-12, security patches were released by Xen and applied to  of 2016-12, security patches were released by Xen and applied to
 pkgsrc.  Xen 4.6 similarly requires a NetBSD/amd64 dom0, but domUs can  pkgsrc.  Xen 4.6 similarly requires a NetBSD/amd64 dom0, but domUs can
 be amd64 or i386 PAE.  TODO: It is either a somewhat aggressive choice  be amd64 or i386 PAE.  For new installations, 4.6 is probably the
 or the standard choice.  appropriate choice and it will likely soon be the standard approach.
   
 Xen 4.7 (released 2016-06) and 4.8 (released 2016-12) are not yet in  Xen 4.7 (released 2016-06) and 4.8 (released 2016-12) are not yet in
 pkgsrc.  pkgsrc.
Line 456  one is using xm or xl.  The Xen 3.1, 3.3 Line 456  one is using xm or xl.  The Xen 3.1, 3.3
 4.2 and up packages use xl.  To use xm with 4.2, edit xendomains to  4.2 and up packages use xl.  To use xm with 4.2, edit xendomains to
 use xm instead.  use xm instead.
   
 For "xm", you should enable xend and xenbackendd:  For 3.1 and 3.3, you should enable xend and xenbackendd:
   
         xend=YES          xend=YES
         xenbackendd=YES          xenbackendd=YES
   
 For "xl", you should enable xend and xencommons (xenstored).  Trying  For 4.1 and up, you should enable xencommons.  Not enabling xencommons
 to use xl without xencommons=YES will result in a hang; it is  will result in a hang; it is necessary to hit ^C on the console to let
 necessary to hit ^C on the console to let the machine finish booting.  the machine finish booting.  If you are using xm (default in 4.1, or
 TODO: Check if xend really should be used, and if not why it is  if you changed xendomains in 4.2), you should also enable xend:
 installed.  
   
         xend=YES          xend=YES # only if using xm, and only installed <= 4.2
         xencommons=YES          xencommons=YES
   
 TODO: Recommend for/against xen-watchdog.  TODO: Recommend for/against xen-watchdog.

Removed from v.1.130  
changed lines
  Added in v.1.132


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb