Diff for /wikisrc/ports/xen/howto.mdwn between versions 1.115 and 1.119

version 1.115, 2016/12/20 13:16:43 version 1.119, 2016/12/20 16:06:08
Line 30  style is less efficient but can run unmo Line 30  style is less efficient but can run unmo
 Generally any amd64 machine will work with Xen and PV guests.  In  Generally any amd64 machine will work with Xen and PV guests.  In
 theory i386 computers without amd64 support can be used for Xen <=  theory i386 computers without amd64 support can be used for Xen <=
 4.2, but we have no recent reports of this working (this is a hint).  4.2, but we have no recent reports of this working (this is a hint).
 For HVM guests, the VT or VMX CPU feature (Intel) or SVM/HVM/VT  For HVM guests, hardware support is needed, but it is common on recent
 (amd64) is needed; "cpuctl identify 0" will show this.  TODO: Clean up  machines.  For Intel CPUs, one needs the VT-x extension, shown in
 and check the above features.  "cpuctl identify 0" as VMX.  For AMD CPus, one needs the AMD-V
   extensions, shown in "cpuctl identify 0" as SVM.  There are further
   features for IOMMU virtualization, Intel's VT-d and AMD's AMD-Vi.
   TODO: Explain whether Xen on NetBSD makes use of these features.
   TODO: Review by someone who really understands this.
   
   Note a FreeBSD dom0 requires VT-x and VT-d (or equivalent); this is
   because the FreeBSD dom0 does not run in PV mode.
   
 At boot, the dom0 kernel is loaded as a module with Xen as the kernel.  At boot, the dom0 kernel is loaded as a module with Xen as the kernel.
 The dom0 can start one or more domUs.  (Booting is explained in detail  The dom0 can start one or more domUs.  (Booting is explained in detail
Line 104  need to use xm instead of xl, or if you  Line 111  need to use xm instead of xl, or if you 
 (because your hardware is i386 only).  (because your hardware is i386 only).
   
 xenkernel45 provides Xen 4.5.  As of 2016-12, security patches were  xenkernel45 provides Xen 4.5.  As of 2016-12, security patches were
 released by Xen and applied to pkgsrc.  Xen 4.5 requires an amd64  released by Xen and applied to pkgsrc.  Xen 4.5 requires using a dom0
 dom0, but domUs can be amd64 or i386 PAE.  TODO: It is either a  running NetBSD's amd64 port (Intel or AMD hardware is fine), but domUs
 conservative choice or somewhat old.  can be amd64 or i386 PAE.  TODO: It is either a conservative choice or
   somewhat old.
   
 xenkernel46 provides Xen 4.6.  It is new to pkgsrc as of 2016-05.  As  xenkernel46 provides Xen 4.6.  It is new to pkgsrc as of 2016-05.  As
 of 2016-12, security patches were released by Xen and applied to  of 2016-12, security patches were released by Xen and applied to
 pkgsrc.  Xen 4.6 requires an amd64 dom0, but domUs can be amd64 or  pkgsrc.  Xen 4.6 similarly requires a NetBSD/amd64 dom0, but domUs can
 i386 PAE.  TODO: It is either a somewhat aggressive choice or the  be amd64 or i386 PAE.  TODO: It is either a somewhat aggressive choice
 standard choice  or the standard choice.
   
 Xen 4.7 (released 2016-06) and 4.8 (released 2016-12) are not yet in  Xen 4.7 (released 2016-06) and 4.8 (released 2016-12) are not yet in
 pkgsrc.  pkgsrc.
Line 140  NetBSD Line 148  NetBSD
 The netbsd-6, netbsd-7, and -current branches are all reasonable  The netbsd-6, netbsd-7, and -current branches are all reasonable
 choices, with more or less the same considerations for non-Xen use.  choices, with more or less the same considerations for non-Xen use.
 Therefore, netbsd-7 is recommended as the stable version of the most  Therefore, netbsd-7 is recommended as the stable version of the most
 recent release for production use.  For those wanting to learn Xen or  recent release for production use.  In addition, netbsd-7 and -current
 without production stability concerns, netbsd-7 is still likely most  have a important scheduler fix (in November of 2015) affecting
 appropriate, but -current is also a reasonable choice.  Xen runs fine  contention between dom0 and domUs; see
 on netbsd-5, but the xentools packages are likely difficult to build.  https://releng.netbsd.org/cgi-bin/req-7.cgi?show=1040 for a
   description.  For those wanting to learn Xen or without production
   stability concerns, netbsd-7 is still likely most appropriate, but
   -current is also a reasonable choice.  (Xen runs ok on netbsd-5, but
   the xentools packages are likely difficult to build, and netbsd-5 is
   not supported.)
   
 As of NetBSD 6, a NetBSD domU will support multiple vcpus.  There is  As of NetBSD 6, a NetBSD domU will support multiple vcpus.  There is
 no SMP support for NetBSD as dom0.  (The dom0 itself doesn't really  no SMP support for NetBSD as dom0.  (The dom0 itself doesn't really
Line 1093  TODO items for improving NetBSD/xen Line 1106  TODO items for improving NetBSD/xen
 Random pointers  Random pointers
 ===============  ===============
   
 TODO: This section contains links from elsewhere not yet integrated  This section contains links from elsewhere not yet integrated into the
 into the HOWTO.  HOWTO, and other guides.
   
 * http://www.lumbercartel.ca/library/xen/  * http://www.lumbercartel.ca/library/xen/
 * http://pbraun.nethence.com/doc/sysutils/xen_netbsd_dom0.html  * http://pbraun.nethence.com/doc/sysutils/xen_netbsd_dom0.html
   * https://gmplib.org/~tege/xen.html

Removed from v.1.115  
changed lines
  Added in v.1.119


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb