Diff for /wikisrc/ports/xen/howto.mdwn between versions 1.113 and 1.116

version 1.113, 2016/12/20 13:09:58 version 1.116, 2016/12/20 14:52:43
Line 30  style is less efficient but can run unmo Line 30  style is less efficient but can run unmo
 Generally any amd64 machine will work with Xen and PV guests.  In  Generally any amd64 machine will work with Xen and PV guests.  In
 theory i386 computers without amd64 support can be used for Xen <=  theory i386 computers without amd64 support can be used for Xen <=
 4.2, but we have no recent reports of this working (this is a hint).  4.2, but we have no recent reports of this working (this is a hint).
 For HVM guests, the VT or VMX CPU feature (Intel) or SVM/HVM/VT  For HVM guests, hardware support is needed, but it is common on recent
 (amd64) is needed; "cpuctl identify 0" will show this.  TODO: Clean up  machines.  For Intel CPUs, one needs the VT-x extension, shown in
 and check the above features.  "cpuctl identify 0" as VMX.  For AMD CPus, one needs the AMD-V
   extensions, shown in "cpuctl identify 0" as SVM.  There are further
   features for IOMMU virtualization, Intel's VT-d and AMD's AMD-Vi.
   TODO: Explain whether Xen on NetBSD makes use of these features.
   TODO: Review by someone who really understands this.
   
 At boot, the dom0 kernel is loaded as a module with Xen as the kernel.  At boot, the dom0 kernel is loaded as a module with Xen as the kernel.
 The dom0 can start one or more domUs.  (Booting is explained in detail  The dom0 can start one or more domUs.  (Booting is explained in detail
Line 103  i386, but only in PAE mode.  The only re Line 107  i386, but only in PAE mode.  The only re
 need to use xm instead of xl, or if you need to run an i386 dom0  need to use xm instead of xl, or if you need to run an i386 dom0
 (because your hardware is i386 only).  (because your hardware is i386 only).
   
 xenkernel45 provides Xen 4.5.  It is no longer maintained by Xen, but  xenkernel45 provides Xen 4.5.  As of 2016-12, security patches were
 as of 2016-12 it received security patches.  Xen 4.5 requires an amd64  released by Xen and applied to pkgsrc.  Xen 4.5 requires an amd64
 dom0, but domUs can be amd64 or i386 PAE.  TODO: It is either a  dom0, but domUs can be amd64 or i386 PAE.  TODO: It is either a
 conservative choice or somewhat old.  conservative choice or somewhat old.
   
 xenkernel45 provides Xen 4.6.  It is new to pkgsrc in 2016-05.  It is  xenkernel46 provides Xen 4.6.  It is new to pkgsrc as of 2016-05.  As
 no longer maintained by Xen, but as of 2016-12 it received security  of 2016-12, security patches were released by Xen and applied to
 patches.  Xen 4.6 requires an amd64 dom0, but domUs can be amd64 or  pkgsrc.  Xen 4.6 requires an amd64 dom0, but domUs can be amd64 or
 i386 PAE.  TODO: It is either a somewhat aggressive choice or the  i386 PAE.  TODO: It is either a somewhat aggressive choice or the
 standard choice  standard choice
   
 Xen 4.7 and 4.8 are not in pkgsrc.  Xen 4.7 (released 2016-06) and 4.8 (released 2016-12) are not yet in
   pkgsrc.
   
 See also the [Xen Security Advisory page](http://xenbits.xen.org/xsa/).  See also the [Xen Security Advisory page](http://xenbits.xen.org/xsa/).
   

Removed from v.1.113  
changed lines
  Added in v.1.116


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb