Diff for /wikisrc/ports/evbarm/raspberry_pi.mdwn between versions 1.27 and 1.32

version 1.27, 2015/01/29 21:28:16 version 1.32, 2015/02/05 23:39:59
Line 97  This page attempts to document and coord Line 97  This page attempts to document and coord
 # GPU  # GPU
   
 ## Video playback  ## Video playback
 Accelerated video playback is supported in NetBSD 7 with the [OMXPlayer](http://pkgsrc.se/multimedia/omxplayer) application.  Accelerated video playback is supported in NetBSD 7 with the [OMXPlayer](http://pkgsrc.se/multimedia/omxplayer) application and through GStreamer with the [omx](http://pkgsrc.se/multimedia/gst-plugins1-omx) plugin.
   
 ## OpenGL ES  ## OpenGL ES
 Accelerated OpenGL ES is supported in NetBSD 7. The GL ES client libraries are included with the [misc/raspberrypi-userland](http://pkgsrc.se/misc/raspberrypi-userland) package.  Accelerated OpenGL ES is supported in NetBSD 7. The GL ES client libraries are included with the [misc/raspberrypi-userland](http://pkgsrc.se/misc/raspberrypi-userland) package.
   
 ### Quake 3  ## Quake 3
 A Raspberry Pi optimized build of *ioquake3* is available in the [games/ioquake3-raspberrypi](http://pkgsrc.se/games/ioquake3-raspberrypi) package. To use it, the following additional resources are required:  A Raspberry Pi optimized build of *ioquake3* is available in the [games/ioquake3-raspberrypi](http://pkgsrc.se/games/ioquake3-raspberrypi) package. To use it, the following additional resources are required:
   
  - pak0.pk3 from Quake 3 CD   - pak0.pk3 from Quake 3 CD
  - additional pak files from http://ioquake3.org/extras/patch-data/   - additional pak files from the [games/ioquake3-pk3](http://pkgsrc.se/games/ioquake3-pk3) package
  - read/write permissions on /dev/vchiq and /dev/wsmouse   - read/write permissions on /dev/vchiq and /dev/wsmouse
   
 Place the .pk3 files in ~/.q3a/baseq3 and ~/.q3a/missionpack directories.  Place the pak0.pk3 file in the /usr/pkg/lib/ioquake3/baseq3 directory.
   
   ## RetroArch / Libretro
   Using [emulators/retroarch](http://pkgsrc.se/emulators/retroarch) it is possible to run many emulators at full speed the Raspberry Pi. Emulator cores for various gaming consoles are available in the [emulators/libretro-*](http://pkgsrc.se/search.php?so=libretro-) packages. To begin using retroarch:
   
    - Install [emulators/retroarch](http://pkgsrc.se/emulators/retroarch)
    - Install the libretro core for the system you would like to emulate (lets take [emulators/libretro-gambatte](http://pkgsrc.se/emulators/libretro-gambatte), a GameBoy Color emulator, as an example).
    - Plug in a USB HID compatible Gamepad, such as the Logitech F710 in "DirectInput" mode (set "D/X" switch to "D").
    - Create a config file for your gamepad using *retroarch-joyconfig*.
   [[!template  id=programlisting text="""
   $ retroarch-joyconfig -o gamepad.cfg -a
   """]]
    - Launch the emulator from the command-line (no X required):
   [[!template  id=programlisting text="""
   $ retroarch --appendconfig gamepad.cfg -L /usr/pkg/lib/libretro/gambatte_libretro.so game.gbc
   """]]
   
 # Additional links  # Additional links
  - [ARM userland utilities](https://github.com/jaredmcneill/userland)   - [ARM userland utilities](https://github.com/jaredmcneill/userland)
   
 # What works in -current  # What works (NetBSD 7.0+)
  - multi-user boot with root on SD card   - multi-user boot with root on SD card
  - serial or graphics console (with EDID query / parsing)   - serial or graphics console (with EDID query / parsing)
  - DMA controller driver and sdhc(4) support   - DMA controller driver and sdhc(4) support
Line 123  Place the .pk3 files in ~/.q3a/baseq3 an Line 138  Place the .pk3 files in ~/.q3a/baseq3 an
  - GPIO   - GPIO
  - RNG   - RNG
  - SPI: could use enhancements, man page   - SPI: could use enhancements, man page
  - VCHIQ: man page missing.   - GPU (VCHIQ) - 3D and video decode. man page missing.
  - USB (host) - dwctwo(4)   - USB (host) - dwctwo(4)
  - USB Ethernet - usmsc(4)   - USB Ethernet - usmsc(4)
  - X windows.   - X windows.

Removed from v.1.27  
changed lines
  Added in v.1.32


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb