Diff for /wikisrc/ports/evbarm/raspberry_pi.mdwn between versions 1.127 and 1.135

version 1.127, 2020/06/19 12:56:59 version 1.135, 2020/10/15 19:58:19
Line 1 Line 1
 [[!meta title="NetBSD/evbarm on Raspberry Pi"]]  [[!meta title="NetBSD/evbarm on Raspberry Pi"]]
   
 This page describes the NetBSD/evbarm port on [Raspberry Pi](http://www.raspberrypi.org) hardware.  All [board variants](https://en.wikipedia.org/wiki/Raspberry_Pi#Specifications) earlier than the RPI4 are believed supported, and specific boards known to work are listed.  We use e.g. "RPI2" to refer to "Raspberry Pi 2" to save precious bytes on this page.  This web page is still 32-bit (aarch32) centric, even though as of mid 2020 aarch64 is also a normal approach.  This page describes the NetBSD/evbarm port on [Raspberry Pi](http://www.raspberrypi.org) hardware.  All [board variants](https://en.wikipedia.org/wiki/Raspberry_Pi#Specifications) earlier than the RPI4 are believed supported, and specific boards known to work are listed.  We use e.g. "RPI2" to refer to "Raspberry Pi 2" to save precious bytes on this page.  This web page is still 32-bit (aarch32) centric, even though as of mid-2020 aarch64 is also a normal approach.
   
 Initial, limited, Raspberry Pi support was introduced in NetBSD 6.0.  NetBSD 7.0 added complete support for the board, along with introducing support for the quad-core Raspberry Pi 2 board.  Raspberry Pi 3 support was added for NetBSD 8.  NetBSD 9 supports aarch64, meaning using the newer processors in 64-bit mode (via -current in mid 2018).  Initial, limited, Raspberry Pi support was introduced in NetBSD 6.0.  NetBSD 7.0 added complete support for the board, along with introducing support for the quad-core Raspberry Pi 2 board.  Raspberry Pi 3 support was added for NetBSD 8.  NetBSD 9 supports aarch64, meaning using the newer processors in 64-bit mode (via -current in mid 2018).
   
 Overall, this page takes the view that NetBSD 7 and earlier are obsolete; aside from history, it is written as if those versions don't exist.  Overall, this page takes the view that NetBSD 7 and earlier are obsolete; aside from history, it is written as if those versions don't exist.
   
   The HOWTO is written for what works on formal releases, release branches (e.g. netbsd-9) and NetBSD-current.  It purposefully does not contain instructions about how to get things to work by installing code that is still being tested and not yet in -current.
   
 [[images/raspberrypi.jpg]]  [[images/raspberrypi.jpg]]
   
 [[!toc levels=2]]  [[!toc levels=2]]
Line 16  Overall, this page takes the view that N Line 18  Overall, this page takes the view that N
   
 "Works" is primarily relative to the earmv6hf-el and earmv7hf-el CPU targets (32-bit).  "Works" is primarily relative to the earmv6hf-el and earmv7hf-el CPU targets (32-bit).
   
 ## NetBSD 7 and NetBSD 8  ## NetBSD 8
   
  - RPI1, RPI2, RPI2-1.2, RPI3, RPI3+ (except RPI3 builtin WiFi and bluetooth)   - RPI1, RPI2, RPI2-1.2, RPI3, RPI3+ (except RPI3 builtin WiFi and bluetooth)
  - RPI0 and RPI0W are expected to work (without WiFi, and one needs fdt files \todo where from?)   - RPI0 and RPI0W are expected to work (without WiFi, and one needs fdt files \todo where from?)
Line 49  Overall, this page takes the view that N Line 51  Overall, this page takes the view that N
    These items do not work in the sense that they simply function after a standard install.  Being listed here implies only that there has been list traffic that implies that after taking a bunch of steps (e.g. new firmware, new dtbs, enabling drivers, applying patches), one can end up with the feature working.  The HOWTO explicitly refrains from describing these steps because they are ephemeral.  However, the fact that list traffic indicates success is possible is a clue that proper support is on the horizon, and that is notable.     These items do not work in the sense that they simply function after a standard install.  Being listed here implies only that there has been list traffic that implies that after taking a bunch of steps (e.g. new firmware, new dtbs, enabling drivers, applying patches), one can end up with the feature working.  The HOWTO explicitly refrains from describing these steps because they are ephemeral.  However, the fact that list traffic indicates success is possible is a clue that proper support is on the horizon, and that is notable.
   
  - RPI3 and RPI0W builtin WiFi   - RPI3 and RPI0W builtin WiFi
    - RPI4
   
 ## What needs documenting if it works  ## What needs documenting if it works
   
    - (Everything listed in the previous section.)
  - CM1   - CM1
  - CM3   - CM3
  - CM3lite   - CM3lite
   
 ## What needs work  ## What needs work
   
  - RPI4 (as of 2020-01, still does not work in current)  
  - USB (host); isochronous transfers.   - USB (host); isochronous transfers.
  - RPI0W Bluetooth Low Energy (probably)   - RPI0W Bluetooth Low Energy (probably)
   
Line 76  Note that one can run a build of earmv6h Line 79  Note that one can run a build of earmv6h
   
 In theory the code compiled for earmv7hf will be faster, but anecdotal experience is that it doesn't matter that much.  \todo Post a link to a quality benchmark.  In theory the code compiled for earmv7hf will be faster, but anecdotal experience is that it doesn't matter that much.  \todo Post a link to a quality benchmark.
   
 While the evbarm port has "eb" variants (for big-endian mode), the RPI systems do not support eb and these variants will not work.  Systems built with older CPU architectures (earm, earmv4, earmv5) are not expected to work on RPI.  While the evbarm port has "eb" variants (for big-endian mode), the RPI systems do not support eb and these variants will not work.  Systems built for older CPU architectures (earm, earmv4, earmv5) are not expected to work on RPI.
   
 The RPI2-1.2 and RPI3 have an armv8 CPU that supports aarch64 (64-bit  The RPI2-1.2, RPI3 and RPI4 have an armv8 CPU that supports aarch64 (64-bit mode) in addition to aarch32 (regular 32-bit ARM).  This is supported, from 9 onwards, by the "aarch64" MACHINE_ARCH of evbarm, also available in build.sh via the alias evbarm64.  This is also referred to as [[NetBSD/aarch64|aarch64]].
 mode) in addition to aarch32 (regular 32-bit ARM).  This is supported,  
 from 9 onwards, by the "aarch64" MACHINE_ARCH of evbarm, also  
 available in build.sh via the alias evbarm64.  This is also  
 referred to as [[NetBSD/aarch64|aarch64]].  
   
 # Installation  # Installation
   
Line 91  referred to as [[NetBSD/aarch64|aarch64] Line 90  referred to as [[NetBSD/aarch64|aarch64]
 The Raspberry Pi looks for firmware and kernel.img on the first FAT32 MBR partition of the uSD card.  A separate kernel (kernel7.img) is used on RPI2 and RPI3.  The Raspberry Pi looks for firmware and kernel.img on the first FAT32 MBR partition of the uSD card.  A separate kernel (kernel7.img) is used on RPI2 and RPI3.
 The NetBSD kernel will then find NetBSD MBR partition and within that the root disklabel partition, and use that FFS partition as the root filesystem.  The NetBSD kernel will then find NetBSD MBR partition and within that the root disklabel partition, and use that FFS partition as the root filesystem.
   
 A 2 GB card is the smallest workable size, and the installation image will fit.  After the first boot, the system resizes the NetBSD root partition to fill the card.  Note that swap is after /boot and before /, and not contained in the NetBSD fdisk partition.  However, if you don't try to change the partition structure, this should not cause you any trouble.  A 2 GB card is the smallest workable size that the installation image will fit on.  After the first boot, the system resizes the NetBSD root partition to fill the card.  Note that swap is after /boot and before /, and not contained in the NetBSD fdisk partition.  However, if you don't try to change the partition structure, this should not cause you any trouble.
   
 Note that SD cards generally have limited write tolerance, so you may wish to disable atime updates via the noatime option, as is done by the default installation.  Note that SD cards generally have limited write tolerance, so you may wish to disable atime updates via the noatime option, as is done by the default installation.
   
Line 117  Consider setting RELEASEMACHINEDIR if yo Line 116  Consider setting RELEASEMACHINEDIR if yo
   
 ### NetBSD autobuild HTTPS/FTP servers  ### NetBSD autobuild HTTPS/FTP servers
   
 NetBSD provides nightly builds on [nycdn.netbsd.org](https://nycdn.netbsd.org/pub/NetBSD-daily/).  The next directory level is the branch being built (netbsd-7, netbsd-8, HEAD, and more), plus optionally things like compiler type.  It is followed by date/time, e.g. "HEAD/201811051650Z"; once a build is complete the symlink "latest" is adjusted to point to it.  The next level is "${MACHINE}-${MACHINE_ARCH}", e.g. "evbarm-earmv7hf", and multiple combinations are provided.  NetBSD provides nightly builds on [nycdn.netbsd.org](https://nycdn.netbsd.org/pub/NetBSD-daily/).  The next directory level is the branch being built (netbsd-8, netbsd-9, HEAD, and more), plus optionally things like compiler type.  It is followed by date/time, e.g. "HEAD/201811051650Z"; once a build is complete the symlink "latest" is adjusted to point to it.  The next level is "${MACHINE}-${MACHINE_ARCH}", e.g. "evbarm-earmv7hf", and multiple combinations are provided.
   
 An example URL, arguably the standard approach for first-time NetBSD/RPI users, is https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-8/latest/evbarm-earmv7hf/binary/gzimg/  An example URL, arguably the standard approach for first-time NetBSD/RPI users, is <https://nycdn.netbsd.org/pub/NetBSD-daily/netbsd-8/latest/evbarm-earmv7hf/binary/gzimg/>
   
 ### release layout  ### release layout
   
Line 160  build.sh (and hence the FTP site) also c Line 159  build.sh (and hence the FTP site) also c
   
  - Connect an Ethernet cable from the RPI to a LAN with a DHCP server, and another host you can use for ssh.   - Connect an Ethernet cable from the RPI to a LAN with a DHCP server, and another host you can use for ssh.
  - Power on the RPI, and wait.  Watch the logs on the DHCP server, and find the IP address assigned to the RPI.   - Power on the RPI, and wait.  Watch the logs on the DHCP server, and find the IP address assigned to the RPI.
  - Use ssh to login to the address you found with user "sysinst", and password "netbsd".   - Use ssh to log in to the address you found with user "sysinst", and password "netbsd".
  - When installing, ensure that you enable DHCP and ssh, so that you can log in again after the system is installed.   - When installing, ensure that you enable DHCP and ssh, so that you can log in again after the system is installed.
   
 The rpi_inst.img.gz image will only work for systems that use earmv6hf kernels (so not RPI2/3).  See [this port-arm message](https://mail-index.netbsd.org/port-arm/2017/08/18/msg004374.html) for details.  The rpi_inst.img.gz image will only work for systems that use earmv6hf kernels (so not RPI2/3).  See [this port-arm message](https://mail-index.netbsd.org/port-arm/2017/08/18/msg004374.html) for details.
Line 187  Note that the built-in WiFi in the RPI3  Line 186  Note that the built-in WiFi in the RPI3 
   
 The following pages have been published by NetBSD community members.  (Note that some of them are old.)  The following pages have been published by NetBSD community members.  (Note that some of them are old.)
   
  - https://www.cambus.net/netbsd-on-the-raspberry-pi/   - <https://www.cambus.net/netbsd-on-the-raspberry-pi/>
   
 # Maintaining a system  # Maintaining a system
   
Line 201  The program vcgencmd, referenced in the  Line 200  The program vcgencmd, referenced in the 
   
 ## Updating the kernel  ## Updating the kernel
   
  - Build a new kernel, e.g. using build.sh. It will tell you where the ELF version of the kernel is, e.g.   - Run uname -a to determine the name of the config of your current kernel.  For NetBSD <= 8, one ran RPI or RPI2.  For NetBSD >=9, one uses GENERIC.
    - Build a new kernel, e.g. using build.sh. Ideally, run "build.sh release" and look in releasedir/binary/kernels.  If building just a kernel, it will tell you where the ELF version of the kernel is, e.g.
          ...           ...
          Kernels built from RPI2:           Kernels built from GENERIC:
           /Users/feyrer/work/NetBSD/cvs/src-current/obj.evbarm-Darwin-XXX/sys/arch/evbarm/compile/RPI2/netbsd            /Users/feyrer/work/NetBSD/cvs/src-current/obj.evbarm-Darwin-XXX/sys/arch/evbarm/compile/GENERIC/netbsd
          ...           ...
    - There are multiple kernel formats produced by a release build, for use with different boot loader schemes..  For GENERIC:
  - Besides the "netbsd" kernel in ELF format, there is also a "netbsd.img" (for current) or "netbsd.bin" (for 7 and 8) kernel that is in a format that the Raspberry can boot.     - netbsd-GENERIC: A normal kernel in ELF format.
      - netbsd-GENERIC.img: In NetBSD >= 9, formatted for the RPI bootloader.
      - netbsd-GENERIC.bin: In NetBSD <= 8, formatted for the RPI bootloader.  In NetBSD >= 9, ??????  In NetBSD 9, this kernel WILL NOT boot.
      - netbsd-GENERIC.ub: A kernel in uboot format.
  - Depending on your hardware version, copy this either to /boot/kernel.img (First generation Pi, Pi Zero hardware) or to /boot/kernel7.img (Pi 2, Pi 3 hardware)   - Depending on your hardware version, copy this either to /boot/kernel.img (First generation Pi, Pi Zero hardware) or to /boot/kernel7.img (Pi 2, Pi 3 hardware)
  - reboot   - reboot
   
 \todo Explain if updating firmware is necessary when e.g. moving from 8 to 9, or 9 to current.  \todo Explain if updating firmware is necessary when e.g. moving from 8 to 9, or 9 to current.
   
   ## Updating dtb files
   
   (This is harder than it should be.)
   Build a release.  gunzip the armv7.img, vnconfig it, and mount the MSDOS partition (e) e.g. on /mnt.  Copy the dtb files from /mnt/foo.dtb to /boot, and from /mnt/dtb/foo.dtb to /mnt/dtb.
   
   It seems that some systems, including RPI, require dtb files in /boot, and some expect them in /boot/dtb.
   
   \todo Explain if you only really need the right one for your system type.
   
   \todo Explain how one is supposed to be able to update these from the dtb files in releasedir/binary/kernel, or fix it to have the same structure.
   
 ## Updating the firmware  ## Updating the firmware
   
   It is highly likely that running NetBSD from a given branch X with firmware from a branch Y < X will not go well.  It is unclear if firmware from a branch Y > X will work.  It is standard practice to use firmware from the right branch.
   
 A section below describes the process of updating NetBSD's copy of the firmware from upstream, with testing, by NetBSD developers.  This section is about updating a system's firmware from the firmware in a version of NetBSD.  A section below describes the process of updating NetBSD's copy of the firmware from upstream, with testing, by NetBSD developers.  This section is about updating a system's firmware from the firmware in a version of NetBSD.
   
   (Updating the firmware is harder than it should be.)
   Build a release.  gunzip the armv7.img, vnconfig it, and mount the MSDOS partition (e) e.g. on /mnt.  Copy files from that to /boot that have changes, carefully.
   
   Relevant files include bootcode.bin, start.elf and start_cd.elf.
   
   Compare cmdline.txt, but beware that just overwriting it will lose customizations like using the serial console instead of the framebuffer.
   
 \todo Explain where the firmware is in the source tree, and note that it is not in the installed system image (such as /usr/mdec).  Explain how to update a system (presumably /boot) from either an installed system's new firmware files, or the source tree.  Explain any particular cautions.  \todo Explain where the firmware is in the source tree, and note that it is not in the installed system image (such as /usr/mdec).  Explain how to update a system (presumably /boot) from either an installed system's new firmware files, or the source tree.  Explain any particular cautions.
   
 \todo Explain if using updated firmware from one branch (e.g. netbsd-current) on a system using a different branch (e.g. netbsd-8) is safe.  Explain if pullups are done to release branches with new firmware.  \todo Explain if using updated firmware from one branch (e.g. netbsd-current) on a system using a different branch (e.g. netbsd-8) is safe.  Explain if pullups are done to release branches with new firmware.
Line 232  One wrinkle in the standard approach is  Line 254  One wrinkle in the standard approach is 
   
 An alternate approach is to have the boot FAT32 partition as above, but to have the entire system including root on an external disk.  This is configured by changing root=ld0a to root=sd0a or root=dk0 (depending on disklabel/GPT).  Besides greater space, part of the point is to avoid writing to the uSD card.  An alternate approach is to have the boot FAT32 partition as above, but to have the entire system including root on an external disk.  This is configured by changing root=ld0a to root=sd0a or root=dk0 (depending on disklabel/GPT).  Besides greater space, part of the point is to avoid writing to the uSD card.
   
 A third approach, workable on the Pi 3 only, is to configure USB host booting (already enableed on the 3+; see the upstream documentation) and have the boot partition also on the external device.  In this case the external device must have an MBR because the hardware's first-stage boot does not have GPT support. In theory the [procedure to program USB host boot mode](https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md) will function on a NetBSD system because the programming is done by bootcode.bin.  A third approach, workable on the Pi 3 only, is to configure USB host booting (already enabled on the 3+; see the upstream documentation) and have the boot partition also on the external device.  In this case the external device must have an MBR because the hardware's first-stage boot does not have GPT support. In theory the [procedure to program USB host boot mode](https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md) will function on a NetBSD system because the programming is done by bootcode.bin.
 \todo Confirm that putting program_usb_boot_mode=1 in config.txt and booting works to program the OTP bit.  Confirm that one can then boot NetBSD from external USB.  \todo Confirm that putting program_usb_boot_mode=1 in config.txt and booting works to program the OTP bit.  Confirm that one can then boot NetBSD from external USB.
   
 There is no well-defined USB enumeration order, so the preferred approach if one has multiple USB mass storage devices is to use named wedges in both fstab and cmdline.txt.  There is no well-defined USB enumeration order, so the preferred approach if one has multiple USB mass storage devices is to use named wedges in both fstab and cmdline.txt.
Line 241  There is no well-defined USB enumeration Line 263  There is no well-defined USB enumeration
   
 \todo Verify this, and add any necessary cautions about boot code.  \todo Verify this, and add any necessary cautions about boot code.
   
 The aarch64 kernel can run aarch32 binaries, so one can boot a aarch64 kernel on a system with aarch32 userland.  The aarch64 kernel can run aarch32 binaries, so one can boot an aarch64 kernel on a system with an aarch32 userland.
   
 # X11 and GPU  # X11 and GPU
   
 ## Video playback  ## Video playback
 Accelerated video playback is supported in NetBSD 7 with the [OMXPlayer](http://pkgsrc.se/multimedia/omxplayer) application and through GStreamer with the [omx](http://pkgsrc.se/multimedia/gst-plugins1-omx) plugin.  
   Accelerated video playback is supported with the [OMXPlayer](http://pkgsrc.se/multimedia/omxplayer) application and through GStreamer with the [omx](http://pkgsrc.se/multimedia/gst-plugins1-omx) plugin.
   
 ## OpenGL ES  ## OpenGL ES
 Accelerated OpenGL ES is supported in NetBSD 7. The GL ES client libraries are included with the [misc/raspberrypi-userland](http://pkgsrc.se/misc/raspberrypi-userland) package.  
   Accelerated OpenGL ES is supported.  The GL ES client libraries are included with the [misc/raspberrypi-userland](http://pkgsrc.se/misc/raspberrypi-userland) package.
   
 ## Quake 3  ## Quake 3
   
 A Raspberry Pi optimized build of *ioquake3* is available in the [games/ioquake3-raspberrypi](http://pkgsrc.se/games/ioquake3-raspberrypi) package. To use it, the following additional resources are required:  A Raspberry Pi optimized build of *ioquake3* is available in the [games/ioquake3-raspberrypi](http://pkgsrc.se/games/ioquake3-raspberrypi) package. To use it, the following additional resources are required:
   
  - pak0.pk3 from Quake 3 CD   - pak0.pk3 from Quake 3 CD
Line 261  A Raspberry Pi optimized build of *ioqua Line 286  A Raspberry Pi optimized build of *ioqua
 Place the pak0.pk3 file in the /usr/pkg/lib/ioquake3/baseq3 directory.  Place the pak0.pk3 file in the /usr/pkg/lib/ioquake3/baseq3 directory.
   
 ## RetroArch / Libretro  ## RetroArch / Libretro
   
 Using [emulators/retroarch](http://pkgsrc.se/emulators/retroarch) it is possible to run many emulators at full speed the Raspberry Pi. Emulator cores for various gaming consoles are available in the [emulators/libretro-*](http://pkgsrc.se/search.php?so=libretro-) packages. To begin using retroarch:  Using [emulators/retroarch](http://pkgsrc.se/emulators/retroarch) it is possible to run many emulators at full speed the Raspberry Pi. Emulator cores for various gaming consoles are available in the [emulators/libretro-*](http://pkgsrc.se/search.php?so=libretro-) packages. To begin using retroarch:
   
  - Install [emulators/retroarch](http://pkgsrc.se/emulators/retroarch)   - Install [emulators/retroarch](http://pkgsrc.se/emulators/retroarch)
Line 301  See the anita section in the evbarm page Line 327  See the anita section in the evbarm page
   
 It is not currently known how to emulate a RPI in qemu, and therefore anita does not yet have support for this.  \todo Add a command-line example to run qemu emulating some RPI model.  It is not currently known how to emulate a RPI in qemu, and therefore anita does not yet have support for this.  \todo Add a command-line example to run qemu emulating some RPI model.
   
   
 # Misc notes  # Misc notes
   
 Miscellaneous notes about Raspberry PI.  Miscellaneous notes about Raspberry PI.
   
 ## Power supply needed (or: why there is a little rainbow square in the top-right corner?)  ## Power supply needed (or: why there is a little rainbow square in the top-right corner?)
   
 Raspberry Pi devices are powered by 5V micro USB and a 2.5A (2500mA)  Raspberry Pi devices are powered by 5V micro USB and a 2.5A (2500mA)
 power supply is recommended.  For more information please read:  power supply is recommended.  For more information please read:
   
Line 322  sd0: cache synchronization failed Line 349  sd0: cache synchronization failed
 Using a recommended power supply avoid such issues.  Using a recommended power supply avoid such issues.
   
 ## Xenon death flash (Raspberry Pi 2 is camera-shy)  ## Xenon death flash (Raspberry Pi 2 is camera-shy)
   
 When using laser pointers or xenon flashes in cameras (or other  When using laser pointers or xenon flashes in cameras (or other
 flashes of high-intensity long-wave light) against a Raspberry Pi  flashes of high-intensity long-wave light) against a Raspberry Pi
 2 the Pi can power itself off.  2 the Pi can power itself off.

Removed from v.1.127  
changed lines
  Added in v.1.135


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb