Diff for /wikisrc/ports/evbarm/raspberry_pi.mdwn between versions 1.113 and 1.114

version 1.113, 2018/11/11 16:48:03 version 1.114, 2018/11/11 16:51:53
Line 1 Line 1
 [[!meta title="NetBSD/evbarm on Raspberry Pi"]]  [[!meta title="NetBSD/evbarm on Raspberry Pi"]]
   
 This page describes the NetBSD/evbarm port on [Raspberry Pi](http://www.raspberrypi.org) hardware.  All [board variants](https://en.wikipedia.org/wiki/Raspberry_Pi#Specifications) are believed supported, and specific boards know to work are listed.  We use e.g. "RPI2" to refer to "Raspberry Pi 2" to save precious bytes on this page.  This page describes the NetBSD/evbarm port on [Raspberry Pi](http://www.raspberrypi.org) hardware.  All [board variants](https://en.wikipedia.org/wiki/Raspberry_Pi#Specifications) are believed supported, and specific boards know to work are listed.  We use e.g. "RPI2" to refer to "Raspberry Pi 2" to save precious bytes on this page.  This web page is 32-bit (aarch32) centric, as that has been until mid-2018 the only approach.
   
 Initial, limited, Raspberry Pi support was introduced in NetBSD 6.0.  NetBSD 7.0 adds complete support for the board, along with introducing support for the quad-core Raspberry Pi 2 board.  Raspberry Pi 3 support was added for NetBSD 8, and backported to NetBSD 7 in July of 2017.  (This page assumes those using NetBSD 7 are using 7.2 or later, but note that everyone uses 8 or -current.)  Initial, limited, Raspberry Pi support was introduced in NetBSD 6.0.  NetBSD 7.0 adds complete support for the board, along with introducing support for the quad-core Raspberry Pi 2 board.  Raspberry Pi 3 support was added for NetBSD 8, and backported to NetBSD 7 in July of 2017.  (This page assumes those using NetBSD 7 are using 7.2 or later, but note that everyone uses 8 or -current.)
   
   In mid-2018, -current gained support for 64-bit ARM (aarch64) support.
   
 [[images/raspberrypi.jpg]]  [[images/raspberrypi.jpg]]
   
 [[!toc levels=2]]  [[!toc levels=2]]
Line 36  Initial, limited, Raspberry Pi support w Line 38  Initial, limited, Raspberry Pi support w
  - RPI3+    - RPI3+ 
  - RPI3 builtin bluetooth   - RPI3 builtin bluetooth
  - RPI3 new SD host controller driver   - RPI3 new SD host controller driver
    - \todo Verify: RPI2-1.2 and RPI3 aarch64
   
 ## What needs documenting if it works  ## What needs documenting if it works
   

Removed from v.1.113  
changed lines
  Added in v.1.114


CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb