Annotation of wikisrc/adobe_flash.mdwn, revision 1.1

1.1     ! mspo        1: Adobe Flash Flash support is available in native NetBSD build browsers such as Mozilla, Netscape, Seamonkey, Firefox and also in Opera (Linux emulation). Please enable official-mozilla-branding in pkgsrc, if you wish to have official Mozilla Branding (results in Firefox User Agent, instead of mozilla buildname, like for exmaple Minefield.) In order to enable flash support you have to do (or check) following steps: 1. Linux emulation needs the folowing addition to **/etc/fstab**: 
        !             2:     
        !             3:     procfs      /usr/pkg/emul/linux/proc     procfs   rw,linux
        !             4:     
        !             5: 
        !             6: Some Linux programs are expecting this to be available. 2. Edit **/etc/mk.conf** file to have: 
        !             7:     
        !             8:     ACCEPTABLE_LICENSES+=flash-license
        !             9:     
        !            10: 
        !            11: This will accept Adobe's EULA. Please read it before you do. 3. Install the actual flash plugin now, it will automatically install the required Linux compatibility files: 
        !            12:     
        !            13:     # cd /usr/pkgsrc/multimedia/adobe-flash-plugin
        !            14:     # make && make install
        !            15:     
        !            16: 
        !            17: 4. Run ldconfig 
        !            18:     <pre><code>
        !            19:     # chroot /usr/pkg/emul/linux /bin/bash
        !            20:     # ldconfig
        !            21:     # exit
        !            22:     </code></pre>
        !            23: 
        !            24: 5. Install the plugin for _firefox_: 
        !            25:     <pre><code>
        !            26:     # nspluginwrapper -v -i /usr/pkg/lib/netscape/plugins/libflashplayer.so
        !            27:     </code></pre>
        !            28: 
        !            29: For flash support in _Opera_ browser: 
        !            30:     
        !            31:     # cd /usr/pkgsrc/www/opera-plugins
        !            32:     # make && make install
        !            33:     
        !            34: 
        !            35: Tell Opera where to find the plugins (You only need to do this if you have older than opera-9.63nb1): 
        !            36:     
        !            37:     $ echo '/usr/pkg/lib/netscape/plugins=1' >> ~/.opera/pluginpath.ini
        !            38:     
        !            39: 
        !            40: 6. Check installation: 
        !            41:     
        !            42:     [http://www.adobe.com/software/flash/about/](http://www.adobe.com/software/flash/about/)
        !            43:     

CVSweb for NetBSD wikisrc <wikimaster@NetBSD.org> software: FreeBSD-CVSweb