A good method of knowing when you have out of date packages is to use the utility lintpkgsrc, which can be ?Installing a package with pkgsrc installed from pkgtools/lintpkgsrc. Once it is installed use it to check installed packages for newer available versions:

lintpkgsrc -i
Scan Makefiles: ................
Version mismatch: 'dummy' 5.1 vs 5.2
Version mismatch: 'other_package' 2.5a vs 2.5b

The results are simple: outdated-package-name currently-installed-version -vs- currently-supported-version See also

?pkg chk

Add a comment