On many systems pkgsrc supports, gcc is the standard compiler. In general, different versions of each OS have different gcc versions, and some packages require newer gcc versions, in order to support newer language standards (e.g. c++11, written in the style of USE_LANGUAGES), or because older versions don't work (infrequently).

This page discusses issues related to version selection, and intends to be a design document for how pkgsrc should address this problem, to be converted into historical design rationale once implemented. It freely takes content from extensive mailinglist discussions, and attempts to follow the rough consensus that has emerged.

Base system gcc vs pkgsrc gcc

Systems using gcc (e.g. NetBSD) have a compiler as /usr/bin/gcc, and this is usable by pkgsrc without any bootstrapping activity. One can build gcc versions (typically newer versions) from pkgsrc, resulting in a compiler within ${PREFIX}, e.g. /usr/pkg/gcc6/bin/gcc. This compiler can then be used to compile other packages.

The Issue with using base system gcc is typically that it is too old, such as gcc 4.5 with NetBSD 6, which cannot compile c++11.

Issues when using pkgsrc gcc are that

Specific constraints and requirements

This section attempts to gather all the requirements.


The above requirements could in theory be satisfied in many ways, but most of them are too complicated. We present a design that aims to be sound while mimimizing complexity.

Remaining issues

gcc dependencies

Because gcc can have dependencies, there could be packages built with the system compiler that are then later used with the chosen version. For now, we defer worrying about these problems (judging that they will be less serious than the current situation where all c++11 programs fail to build on NetBSD 6).

\todo: Analyze what build-time and install-time dependencies actually exist.

\todo: Discuss adjusting options to minimize dependencies, including gcc-inplace-math and nls.

Differing GCC and GXX versions

Perhaps it is a mistake to allow the chosen GCC and GXX versions to differ. If we require them to be the same, then essentially all systems with a base system compiler older than gcc 5 will have to bootstrap the compiler. For now, we allow them to differ and will permit the defaults to differ.

Default versions for various systems

Note that if for any particular system's set of installed packages (or bulk build), a newer gcc has to be built, it does not hurt to have built it earlier.

When the base system is old (e.g., gcc 4.5 in NetBSD 6, or 4.1, in NetBSD 5), then it is clear that a newer version must be built. For these, PKGSRC_GXX_VERSION should default to a newish gcc, avoiding being so new as to cause building issues. Currently, gcc5 is probably a good choice, with gcc6 compiling significantly but not vastly fewer packages. PKGSRC_GCC_VERSION should probably default to the system version if it can build all C99 programs, or match PKGSRC_GXX_VERSION, if the system version is too old. Perhaps gcc 4.5 would be used, but 4.1 not used. \todo Discuss.

When the base system is almost new enough, the decision about the default is more complicated. A key example is gcc 4.8, found in NetBSD 7. Firefox requires gcc 4.9, and all programs using c++14 also need a newer version. One options is to choose 4.8, resulting in firefox failing, as well as all c++14 programs. Another is to choose 4.9, but this makes little sense because c++14 programs will still fail, and the general rule of moving to the most recent generally-acceptable version applies, which currently leads to gcc6. This is in effect a declaration that "almost new enough" does not count as new enough. Thus the plan for NetBSD 7 is to set PKGSRC_GCC_VERSION to 4.8 and PKGSRC_GXX_VERSION to 5.

When the base system is new enough, e.g. gcc 5, 6 or 7 it should simply be used. By "new enough", we mean that almost no programs in pkgsrc fail to build with it, which implies that it supports (almost all) C++14 programs. Our current definiton of new enough is gcc 5.

Limited mixed versions

One approach would be to allow limited mixed versions, where individual programs could force a specific version to be bootstrapped and used, so that e.g. firefox could use 4.9 even though most programs use 4.8, which is what happens now on NetBSD 7. This would rely on being able to link c++ with 4.9 including some things built with 4.8 (which is done presently). However, this approach would become unsound with a library rather than an end program. We reject this as too much complexity for avoiding building a newer compiler in limited situations.


Fortran support is currently somewhat troubled.. It seems obvious to extend to PGKSRC_GFORTRAN_VERSION, and have that match PKGSRC_GCC_VERSION or PKGSRC_GXX_VERSION, but the Fortran situation is not worsened by the above design. \todo Discuss.

Path forward

Later steps

Add a comment
Contact | Disclaimer | Copyright © 1994-2017 The NetBSD Foundation, Inc. ALL RIGHTS RESERVED.
NetBSD® is a registered trademark of The NetBSD Foundation, Inc.